Help pls

community

#1

Warning your system hasn’t been patched against critical windows security vulnerabilites. Please run windows update before june 1st, 2018 to keep using faceit ac


#2

Please see this Reddit thread, there’s a reply from FACEIT AC Team: