Fixes to two common problems (Stuck update + No client/Site API functionality(black interface)

As I had these problems myself the issue seems to point to the network settings, especially if you at some point using VPN’s (The VPN doesn’t re-instate to the previous network settings and thus problems tend to occur on faceit)

Over time, your system will automatically cache IP addresses and other DNS results, in order to speed up subsequent requests it makes to the same hostname. This is all good, but at times, bad results will also be cached and therefore require to be cleared from your cache in order to communicate with hosts correctly.

To fix this on your local machine:

  • From Windows Start, search for cmd.
  • Right click on Command Prompt and click Run as administrator.
  • In the console, type the following command:

ipconfig /flushdns

  • If the command was successful, you will see the message “Successfully flushed the DNS Resolver Cache”.
    Afterwards, type the following commands(Resetting IP/TCP/Network Adapter):

netsh int ip reset
netsh int tcp reset
netsh winsock reset

  • Once done, restart your computer with following command in the command line(Restarting with a full reset of the computer and not in hibernated state or paused apps):

shutdown /r /f /t 0

Alternative: Try change DNS (Google 8.8.8.8, 8.8.4.4; often one that works really good)

  1. Open Control Panel.
  2. Click on Network and Internet.
  3. Click on Network and Sharing Center.
  4. On the left pane, click on Change adapter settings.
  5. Right-click the network interface connected to the internet, and select Properties.
  6. Select Internet Protocol Version 4 (TCP/IPv4) from the list.
  7. Click the Properties button.
  8. Click the Use the following DNS server addresses option.
  9. Type your preferred and alternate DNS server addresses. Here you can enter any DNS servers you want, including from free ones such as Google. Here is Googles Public DNS addresses: 8.8.8.8 and 8.8.4.4

These kind of issues often occur when you use a VPN as it’s changes a lot of the networking features/settings and when you disconnect it often doesn’t re-instate the previous settings nor fully clean the settings from the VPN.

Note: If you are running permanent VPN via your router you might need to change back the DNS settings to the normal ones and regular IP.

If you are changing your DNS to google, you might want to read on upon integrity safety and remember that if you are using VPN clients that they often are re-instating back to default settings yet cache and settings from the VPN may stay after you disconnected, in doing so they also remove your manually changed DNS from example google DNS back to default ISP DNS (so if you want to have google DNS and change it to that, the VPN will automatically re-instate default settings which is ISP so in that way you will always have to change back manually if you don’t have the option to specify which DNS you want as a standard layout when it re-converts back from the VPN live settings to the offline state)

Also read common problems and fixes at faceits AC guideline page:

1 Like

it works!!!

1 Like

Glad it helped :slight_smile:

This is not working… Tried it. Also we are using diskless system I wonder why it stuck up.

What kind of problem do you have?

Stuck at downloading updates…Untitled|690x388

it works thank you very much bro :smiley:

1 Like

If you tried the steps above and still not working take contact with the support.