Faceit


#1

when i go to register csgo it says it is not owned by my steam account. someone help me.


#2

As per this support article:

The error message “It looks like the profile you’re connecting doesn’t have the game or your game privacy settings are not public“ means that your Steam Account’s Game Privacy Settings are set to “Friends Only” or “Private”. To be able to add a game to your FACEIT account, you must have this set to “Public”.

Steps to changing Game Privacy Settings

Head to your Profile Privacy Settings Page (from the Steam Client, head to your profile page > Edit Profile > My Privacy Settings)
Click “▼” next to “Game details” and select Public
Depending on the game you are attempting to add, you may need to untick “Always keep my total playtime private even if users can see my game details.”